[PATCH] D95998: [Debug-Info] [NFC] use emitDwarfUnitLength to handle debug line section unit length field

David Blaikie via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 22 11:53:13 PST 2021


dblaikie added inline comments.


================
Comment at: llvm/lib/MC/MCDwarf.cpp:492
 
+  MCSymbol *SymWithoutUnitLength = context.createTempSymbol("debug_line_");
+
----------------
ikudrin wrote:
> Don't think a prefix for this temporary symbol is needed. Even `ProEndSym`, which is emitted much farther from the expression, does not have it.
> 
> And maybe rename it to something like `ProStartSym` to match the other one?
Generally names help with editing/reading/modifying/FileChecking the assembly.

ProEndSym even has a comment that "suggests" a name but doesn't use it - I don't know why it doesn't actually name the temp symbol - it probably should.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D95998/new/

https://reviews.llvm.org/D95998



More information about the llvm-commits mailing list