[PATCH] D97069: [clang] BoolMOption helper in Options.td

Jan Svoboda via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 22 00:14:03 PST 2021


jansvoboda11 requested changes to this revision.
jansvoboda11 added inline comments.
This revision now requires changes to proceed.


================
Comment at: clang/include/clang/Driver/Options.td:431
+// specified by the OptGroup argument, otherwise Group<m_Group>.
+multiclass BoolMOption<string flag_base,
+                       string HelpStringEnabled, string HelpStringDisabled,
----------------
Can you please rename this to `BoolMFlag` and model it after `BoolFFlag`?

The `Bool?Option` multiclasses were created for fine-grained control of cc1 flag marshalling, which your implementation doesn't do/need. https://clang.llvm.org/docs/InternalsManual.html#option-marshalling-infrastructure


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D97069/new/

https://reviews.llvm.org/D97069



More information about the llvm-commits mailing list