[PATCH] D96636: [lld][ELF] Support for zero flag section groups

James Henderson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 15 02:08:48 PST 2021


jhenderson accepted this revision.
jhenderson added a comment.

Looks good, with a couple of small comments.



================
Comment at: lld/ELF/InputFiles.cpp:621
 
       bool isNew =
+          (flag & GRP_COMDAT) == 0 || ignoreComdats ||
----------------
I wonder whether `isNew` is a bit misnamed nowadays. Perhaps it should be renamed to `keepGroup` or something like that. Waht do you think?


================
Comment at: lld/test/ELF/gc-sections-group.s:65
+
+## These seections are in a COMDAT group `cmdt`.
+.globl anote_cmdt, cmdt, bss_cmdt, note_cmdt
----------------



CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D96636/new/

https://reviews.llvm.org/D96636



More information about the llvm-commits mailing list