[PATCH] D94741: [Utils][WIP] Check for more global information in update_test_checks

Mircea Trofin via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 8 07:04:38 PST 2021


mtrofin added inline comments.
Herald added a reviewer: bollu.


================
Comment at: llvm/utils/UpdateTestChecks/common.py:377
 class NamelessValue:
-    def __init__(self, check_prefix, ir_prefix, ir_regexp):
+    def __init__(self, check_prefix, check_key, ir_prefix, global_ir_prefix, global_ir_prefix_regexp, ir_regexp, global_ir_rhs_regexp, is_before_functions):
         self.check_prefix = check_prefix
----------------
nit: could you run a linter to split, insomuch as possible, long lines? I (think I) know we don't enforce a code style of .py, but I'd argue there's readability value in doing it. (no need to scroll right, less eye movement effort)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D94741/new/

https://reviews.llvm.org/D94741



More information about the llvm-commits mailing list