[PATCH] D93064: RegisterCoalescer: Prune undef subranges from copy pairs in loops

Quentin Colombet via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 3 10:16:26 PST 2021


qcolombet accepted this revision.
qcolombet added a comment.
This revision is now accepted and ready to land.

LGTM with nit on the function name.



================
Comment at: llvm/lib/CodeGen/RegisterCoalescer.cpp:3120
+// to handle).
+static bool mayBeUndefSubrangeLiveThrough(const LiveQueryResult Q) {
+  return Q.valueIn() && Q.valueIn()->isPHIDef() && Q.valueIn() == Q.valueOut();
----------------
I don't really like the function name here:
We don't test for undef and we don't have anything specific for subrange.

Maybe rename in `isLiveThrough`?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D93064/new/

https://reviews.llvm.org/D93064



More information about the llvm-commits mailing list