[PATCH] D95044: IR+AArch64: add `swiftasync` function parameter attribute

Tim Northover via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 28 01:20:17 PST 2021


t.p.northover added inline comments.


================
Comment at: llvm/include/llvm/Bitcode/LLVMBitCodes.h:659
   ATTR_KIND_HOT = 72,
+  ATTR_KIND_SWIFT_ASYNC = 73,
 };
----------------
varungandhi-apple wrote:
> This is going to hit a merge conflict or a miscompile; on `main`, 73 is already taken by `ATTR_KIND_NO_PROFILE`.
Yep, for this kind of thing the last step is always going to be rebasing and refreshing magic constants. If I've done my job right, the regression tests should be enough to flag it even if I forget.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D95044/new/

https://reviews.llvm.org/D95044



More information about the llvm-commits mailing list