[PATCH] D93476: [LV][ARM] Inloop reduction cost modelling

Dave Green via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jan 19 07:22:11 PST 2021


dmgreen added a comment.

In D93476#2506583 <https://reviews.llvm.org/D93476#2506583>, @spatel wrote:

> I'm not up-to-date with the current state of MVE and other Arm ISA additions, so others should feel free to chime in. :)
> Instead of adding a specialization parameter for MLA to normal math reductions, would it be simpler/cleaner to add a dedicated cost model API for MLA? For example, we already distinguish min/max from other ops via getMinMaxReductionCost().

Thanks for the suggestion! That does sound like a good idea. I've added one called getExtendedReductionCost to handle vecreduce.add(ext) and vecreduce.add(mul(ext, ext)), but let me know if it could be named better.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D93476/new/

https://reviews.llvm.org/D93476



More information about the llvm-commits mailing list