[PATCH] D93402: [clang-tidy] prevent readability-identifier-naming from triggering on implicit VarDecls in coroutines

Emma Blink via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 16 08:41:29 PST 2020


0x1eaf created this revision.
0x1eaf added reviewers: alexfh, njames93, aaron.ballman.
0x1eaf added projects: clang, clang-tools-extra.
Herald added subscribers: lxfind, modocache, xazax.hun.
0x1eaf requested review of this revision.
Herald added a subscriber: cfe-commits.

We have an internal bug report about readability-identifier-naming
warnings on implicit `__coro_gro` and `__promise` variables
in coroutines.

Turns out they haven't been marked as implicit in SemaCoroutine.
This diff resolves that and adds a couroutine test for the check.

Tested with:

> cd build/Debug/bin
> ./llvm-lit -sv --param build_mode=Debug \

  ../../tools/clang/tools/extra/test \
  --filter readability-identifier-naming.cpp


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D93402

Files:
  clang-tools-extra/test/clang-tidy/checkers/Inputs/readability-identifier-naming/system/coroutines.h
  clang-tools-extra/test/clang-tidy/checkers/readability-identifier-naming.cpp
  clang/lib/Sema/SemaCoroutine.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D93402.312224.patch
Type: text/x-patch
Size: 3954 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20201216/e2f57abb/attachment.bin>


More information about the llvm-commits mailing list