[PATCH] D92584: [CSSPGO][llvm-profgen] Refactor to unify hashable interface for trace sample and context-sensitive counter

Wei Mi via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Dec 14 12:39:40 PST 2020


wmi added inline comments.


================
Comment at: llvm/tools/llvm-profgen/PerfReader.h:301
+// Sample counter with context to support context-sensitive profile
+using ContextSampleCounter =
+    std::unordered_map<Hashable<ContextKey>, SampleCounter,
----------------
Can we rename it to ContextSampleCounterMap and its object to something like CtxCounterMap? 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D92584/new/

https://reviews.llvm.org/D92584



More information about the llvm-commits mailing list