[PATCH] D92909: [WebAssembly] Add support for named data sections in wasm binaries

Thomas Lively via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 9 12:30:40 PST 2020


tlively accepted this revision.
tlively added inline comments.
This revision is now accepted and ready to land.


================
Comment at: llvm/lib/Object/WasmObjectFile.cpp:378
         StringRef Name = readString(Ctx);
+        wasm::NameType T = wasm::NameType::FUNCTION;
         if (Type == wasm::WASM_NAMES_FUNCTION) {
----------------
It would be good to give a more descriptive name to `T` now that it is no longer used directly after it is declared.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D92909/new/

https://reviews.llvm.org/D92909



More information about the llvm-commits mailing list