[PATCH] D92932: RegionInfo: use a range-based for loop [NFCI]

David Blaikie via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 9 11:14:46 PST 2020


dblaikie accepted this revision.
dblaikie added a comment.
This revision is now accepted and ready to land.

Yeah, looks good - generally no need to send things like this sort of cleanup for review (can be committed directly/for post-commit review).

I guess this could even be replaced by something like:

  return llvm::none_of(*entrySuccs, [&](BlockT* successor) {
    return successor != exit && successor != entry;
  });

Not sure if that's better/more readable or not, up to you.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D92932/new/

https://reviews.llvm.org/D92932



More information about the llvm-commits mailing list