[PATCH] D92518: [msan] Use REAL macro when calling intercepted function

Tom Stellard via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 3 17:17:39 PST 2020


tstellar added a comment.

In D92518#2432531 <https://reviews.llvm.org/D92518#2432531>, @eugenis wrote:

> This code needs to call the interceptor to unpoison the output buffer.
>
> As an alternative, unpoison the buffer after the REAL call (just copy the chunk from the previous function).
>
> What problem does this change solve?

It fixes a compile error introduced  in  D92521 <https://reviews.llvm.org/D92521> where I attempt to change the name of the interceptor.  I thought based on the comments that the REAL() macro was necessary, but sound like I was wrong.  Maybe it would be best to look at D92521 <https://reviews.llvm.org/D92521> first, because that is the main problem I'm trying to fix.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D92518/new/

https://reviews.llvm.org/D92518



More information about the llvm-commits mailing list