[PATCH] D91724: [HardwareLoops] Change order of SCEV expression construction for InitLoopCount.
Janek van Oirschot via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 23 08:50:18 PST 2020
JanekvO updated this revision to Diff 307093.
JanekvO added a comment.
Rename ExitCount to TripCount and move SCAV expression construction outside of HardwareLoops pass into isHardwareLoopCandidate.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D91724/new/
https://reviews.llvm.org/D91724
Files:
llvm/lib/Analysis/TargetTransformInfo.cpp
Index: llvm/lib/Analysis/TargetTransformInfo.cpp
===================================================================
--- llvm/lib/Analysis/TargetTransformInfo.cpp
+++ llvm/lib/Analysis/TargetTransformInfo.cpp
@@ -218,8 +218,7 @@
ExitBlock = BB;
TripCount = SE.getAddExpr(EC, SE.getOne(EC->getType()));
- if (!EC->getType()->isPointerTy() &&
- EC->getType() != CountType)
+ if (!EC->getType()->isPointerTy() && EC->getType() != CountType)
TripCount = SE.getZeroExtendExpr(TripCount, CountType);
break;
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D91724.307093.patch
Type: text/x-patch
Size: 540 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20201123/ba3a29fc/attachment.bin>
More information about the llvm-commits
mailing list