[PATCH] D90243: [NFC] [LLParser] Renaming LLParser routines to satisfy LLVM coding style

Alok Kumar Sharma via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 27 09:07:20 PDT 2020


alok created this revision.
alok added reviewers: aprantl, djtodoro, SouraVX, jini.susan.george.
alok added a project: debug-info.
Herald added subscribers: llvm-commits, jfb, hiraditya.
Herald added a reviewer: sscalpone.
Herald added a project: LLVM.
alok requested review of this revision.

This patch does not change any functionality.

Renaming of functions in LLParser.cpp/LLParser.h is done to satisfy coding style.

This was needed while D89218 <https://reviews.llvm.org/D89218> was done. clang-tidy was unhappy over newly added function  LLParser::ParseDIGenericSubrange.

---------------

/mnt/disks/ssd0/agent/llvm-project/llvm/lib/AsmParser/LLParser.cpp:4599:16: warning: invalid case style for function 'ParseDIGenericSubrange' [readability-identifier-naming]
bool LLParser::ParseDIGenericSubrange(MDNode *&Result, bool IsDistinct) {

^~~~~~~~~~~~~~~~~~~~~~

parseDiGenericSubrange
----------------------

This function is implicitly defined using macro as
--------------------------------------------------

#define HANDLE_SPECIALIZED_MDNODE_LEAF(CLASS)                                  \

  if (Lex.getStrVal() == #CLASS)                                               \
   return Parse##CLASS(N, IsDistinct);

#include "llvm/IR/Metadata.def"
-------------------------------

Change here requires changes all over.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D90243

Files:
  llvm/lib/AsmParser/LLParser.cpp
  llvm/lib/AsmParser/LLParser.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D90243.301011.patch
Type: text/x-patch
Size: 352047 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20201027/8df3c82b/attachment-0001.bin>


More information about the llvm-commits mailing list