[PATCH] D89665: [LSR] ignore profitable chain optimization when instruction number is the major cost
ChenZheng via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Oct 26 19:31:34 PDT 2020
shchenz added inline comments.
================
Comment at: llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp:2870
+ // If register number is the major cost, we cannot benefit from this
+ // profitable chain which is based on register number.
+ // FIXME: add profitable chain optimization for other kinds major cost, for
----------------
jonpa wrote:
> This seems unclear to me - should it be "If register number is *not* the...", or perhaps "*Only* if register..." ?
>
> It would also be a bit more readable to me if the new hook was called "isNumRegsMajorCostOfLSR", since NumRegs is the name for that counter. (And the comment "number of registers").. but maybe that's just me...
>
>
Appreciate the comments. Addressed in NFC patch https://reviews.llvm.org/rG00e573cadb2791804fd0859d0ee05b27b702e11e
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D89665/new/
https://reviews.llvm.org/D89665
More information about the llvm-commits
mailing list