[PATCH] D74729: [FPEnv] Intrinsic for setting rounding mode
Serge Pavlov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Oct 26 08:42:52 PDT 2020
sepavloff added inline comments.
================
Comment at: llvm/include/llvm/CodeGen/ISDOpcodes.h:753
+ /// rounding mode, encoded in the same way as used in '``FLT_ROUNDS_``'.
+ SET_ROUNDING,
+
----------------
RKSimon wrote:
> Sorry for the bikeshedding - but if SET_ROUNDING is supposed to match FLT_ROUNDS - shouldn't it have a more similar name?
It is `FLT_ROUNDS_` that has "wrong" name. It is named after the macro `FLT_ROUNDS`, which is defined by C99. To get better names `FLT_ROUNDS_` must be renamed not `SET_ROUNDING`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74729/new/
https://reviews.llvm.org/D74729
More information about the llvm-commits
mailing list