[PATCH] D89773: [IRCE] consolidate profitability check

Roman Lebedev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Oct 21 04:42:13 PDT 2020


lebedev.ri added inline comments.


================
Comment at: llvm/lib/Transforms/Scalar/InductiveRangeCheckElimination.cpp:246-248
+  // Returns true if it is profitable to do a transform basing on estimation of
+  // number of iterations.
+  bool checkProfitability(const Loop &L, unsigned LatchBrExitIdx);
----------------
lebedev.ri wrote:
> Passing-by nit: the comment suggests the method should be called `isProfitableToTransform()` or something
(please don't wait for me here)


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D89773/new/

https://reviews.llvm.org/D89773



More information about the llvm-commits mailing list