[PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

Louis Dionne via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 20 12:27:23 PDT 2020


ldionne added a comment.

Are generator expressions expanded in `if()`? If so, we could at least change those to `if ("$<UPPER_CASE:CMAKE_BUILD_TYPE>" STREQUAL "DEBUG")`. This would preserve the case-insensitivity while solving the problem you were concerned about, and make the code easier to read.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D89813/new/

https://reviews.llvm.org/D89813



More information about the llvm-commits mailing list