[PATCH] D89773: [IRCE] consolidate profitability check
Roman Lebedev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Oct 20 03:01:21 PDT 2020
lebedev.ri added inline comments.
================
Comment at: llvm/lib/Transforms/Scalar/InductiveRangeCheckElimination.cpp:246-248
+ // Returns true if it is profitable to do a transform basing on estimation of
+ // number of iterations.
+ bool checkProfitability(const Loop &L, unsigned LatchBrExitIdx);
----------------
Passing-by nit: the comment suggests the method should be called `isProfitableToTransform()` or something
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D89773/new/
https://reviews.llvm.org/D89773
More information about the llvm-commits
mailing list