[PATCH] D89004: [LLD] [COFF] Implement a GNU/ELF like -wrap option
Martin Storsjö via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Oct 13 23:16:28 PDT 2020
mstorsjo updated this revision to Diff 298045.
mstorsjo added a comment.
Removed superfluous `lld::coff::` specifiers where possible. Added a testcase for wrapping an imported symbol. (In that case, one can't do the wrapping by replacing the actual Symbol object contents, because that breaks generation of the import thunks.) Didn't rename the `canInline` field yet, pending consensus on what to rename it to.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D89004/new/
https://reviews.llvm.org/D89004
Files:
lld/COFF/Driver.cpp
lld/COFF/InputFiles.h
lld/COFF/LTO.cpp
lld/COFF/MinGW.cpp
lld/COFF/MinGW.h
lld/COFF/Options.td
lld/COFF/SymbolTable.cpp
lld/COFF/Symbols.h
lld/MinGW/Driver.cpp
lld/MinGW/Options.td
lld/test/COFF/wrap-i386.s
lld/test/COFF/wrap-import.ll
lld/test/COFF/wrap-lto-1.ll
lld/test/COFF/wrap-lto-2.ll
lld/test/COFF/wrap-real-missing.s
lld/test/COFF/wrap-with-archive.s
lld/test/COFF/wrap.s
lld/test/MinGW/driver.test
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D89004.298045.patch
Type: text/x-patch
Size: 21774 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20201014/6b702cee/attachment.bin>
More information about the llvm-commits
mailing list