[PATCH] D88982: [NFCI] Add LinearPolyBase as base class for ElementCount, TypeSize and StackOffset.

Sander de Smalen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Oct 8 09:57:54 PDT 2020


sdesmalen updated this revision to Diff 297002.
sdesmalen marked 4 inline comments as done.
sdesmalen retitled this revision from "[NFCI] Add PolyBase as base class for ElementCount, TypeSize and StackOffset." to "[NFCI] Add LinearPolyBase as base class for ElementCount, TypeSize and StackOffset.".
sdesmalen edited the summary of this revision.
sdesmalen added a comment.
Herald added a subscriber: mgorny.

- Renamed PolyBase -> LinearPolyBase, DimIsExclusive -> IsUnivariate, etc.
- Removed `verify()` method.
- Replaced regular array with std::array.
- Changed name of new StackOffset class in TypeSize.h to `NewStackOffset`, so not to clash with the one defined in AArch64StackOffset.h. This is renamed to `StackOffset` in D88983 <https://reviews.llvm.org/D88983> when it removes AArch64StackOffset.h entirely.
- Moved TestStackOffset.cpp from D88983 <https://reviews.llvm.org/D88983> to this patch.
- Updated commit message.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D88982/new/

https://reviews.llvm.org/D88982

Files:
  llvm/include/llvm/Support/TypeSize.h
  llvm/unittests/Support/CMakeLists.txt
  llvm/unittests/Support/StackOffsetTest.cpp
  mlir/include/mlir/Dialect/LLVMIR/LLVMTypes.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D88982.297002.patch
Type: text/x-patch
Size: 23059 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20201008/d72982cd/attachment.bin>


More information about the llvm-commits mailing list