[PATCH] D88737: [AIX] Turn -fdata-sections on by default in Clang

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Oct 7 23:16:14 PDT 2020


MaskRay added inline comments.


================
Comment at: lld/Common/TargetOptionsCommandFlags.cpp:17
+llvm::TargetOptions
+lld::initTargetOptionsFromCodeGenFlags(const llvm::Triple &TheTriple) {
+  return llvm::codegen::InitTargetOptionsFromCodeGenFlags(TheTriple);
----------------
jasonliu wrote:
> MaskRay wrote:
> > Currently lld does not need Triple. Consider not changing the signature of `initTargetOptionsFromCodeGenFlags`.
> This function acts like a forwarder for llvm::codegen::InitTargetOptionsFromCodeGenFlags.
> I think it still makes sense to change the signature in this case to minimize the different variation of the function, as those variations cause confusion to people. 
> I will change the name to match the LLVM style.
If you want to change `InitTargetOptionsFromCodeGenFlags` in an incompatible way, you can by the way rename it to `initTarget*`.

lld functions should always stick with the `camelCase` rule. If there is no meaningful triple, I'd prefer leave out the parameter.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D88737/new/

https://reviews.llvm.org/D88737



More information about the llvm-commits mailing list