[PATCH] D87700: [SVE] Replace / operator in TypeSize/ElementCount with coefficientDiv
Paul Walker via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Sep 24 09:39:42 PDT 2020
paulwalker-arm added a comment.
I think the precedent has already been set as VectorType and ValueType already deem doubling and halving to be special enough to have explicit operations, albeit they save more effort that what's being saved here. Personally I just think
ElementCount.halve()
is more meaningful/readable than
assert(ElementCount.isKnownMultiple(2));
ElementCount.coefficientDiv(2);
Whereas `ElementCount * 2` is already meaningful enough.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D87700/new/
https://reviews.llvm.org/D87700
More information about the llvm-commits
mailing list