[PATCH] D87362: [llvm-readobj/elf] - Simplify and refine the implementation which dumps .stack_sizes
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Sep 15 00:45:03 PDT 2020
jhenderson accepted this revision.
jhenderson added a comment.
This revision is now accepted and ready to land.
LGTM, with nit.
================
Comment at: llvm/tools/llvm-readobj/ELFDumper.cpp:5761-5764
+ for (const auto &P : StackSizeRelocMap) {
PrintHeader();
- const SectionRef &StackSizesSec = StackSizeMapEntry.first;
- const SectionRef &RelocSec = StackSizeMapEntry.second;
- const Elf_Shdr *StackSizesELFSec =
- Obj->getSection(StackSizesSec.getRawDataRefImpl());
+ const Elf_Shdr *StackSizesELFSec = P.first;
+ const Elf_Shdr *RelocSec = P.second;
----------------
Nit: I prefer the old name, since it's more descriptive.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D87362/new/
https://reviews.llvm.org/D87362
More information about the llvm-commits
mailing list