[PATCH] D87087: [llvm-readobj/elf] - Generalize the code for printing dynamic relocations. NFCI.
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Sep 4 01:29:34 PDT 2020
grimar added inline comments.
================
Comment at: llvm/tools/llvm-readobj/ELFDumper.cpp:5495
+template <class ELFT> void DumpStyle<ELFT>::printDynamicRelocationsHelper() {
+ const DynRegionInfo &DynRelaRegion = this->dumper()->getDynRelaRegion();
----------------
jhenderson wrote:
> I think if you move this function to immediately after the `GNUStyle<ELFT>::printDynamicRelocations` function, it will make the diff much easier to follow. As it is, there doesn't seem to be a consistent ordering of `DumpStyle` and `GNUStyle` methods, so keeping the diff/blame history simpler seems beneficial.
Done.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D87087/new/
https://reviews.llvm.org/D87087
More information about the llvm-commits
mailing list