[PATCH] D86497: [lldb] Add reproducer verifier

Raphael Isemann via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 31 09:58:00 PDT 2020


teemperor accepted this revision.
teemperor added a comment.
This revision is now accepted and ready to land.

One nit about naming and another small thing, but otherwise this LGTM.



================
Comment at: lldb/include/lldb/Utility/Reproducer.h:242
+struct ReplayOptions {
+  bool skip_verification = false;
+  bool skip_version_check = false;
----------------
I kinda like `verify = true` a bit better than `skip_verification = false`. 'skip' feels like a negation, so you end up checks like `if (!skip_verification) (`= "if we should not not verify" instead of just `if (verify)`. Same below.

But that's just personal preference so I won't mind the name if you feel strongly about it (and it kinda fits the command line argument names)


================
Comment at: lldb/source/Utility/Reproducer.cpp:337
+  } else {
+    llvm::consumeError(symbol_files.takeError());
+  }
----------------
Maybe log the error to llvm::errs? Or is there no symbol-files.yaml when the replay doesn't involve symbol files, so this is expected?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D86497/new/

https://reviews.llvm.org/D86497



More information about the llvm-commits mailing list