[PATCH] D85910: libclc: Add a __builtin to let SPIRV targets select between SW and HW FMA
Jesse Natalie via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Aug 31 08:56:26 PDT 2020
jenatali added inline comments.
================
Comment at: libclc/generic/lib/math/math.h:45
+bool __attribute__((noinline)) __builtin_has_hw_fma32(void);
+#define HAVE_HW_FMA32() __builtin_has_hw_fma32()
#else
----------------
daniels wrote:
> jvesely wrote:
> > This shouldn't be prefixed `__bultin` that space is reserved for the compiler. Naming it something like `__clc_runtime_has_fma32` would be more fitting.
> Fine by me. @jenatali?
No complaints.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D85910/new/
https://reviews.llvm.org/D85910
More information about the llvm-commits
mailing list