[PATCH] D86472: [Scalarizer] Avoid updating the name of globals
Bjorn Pettersson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Aug 24 10:17:07 PDT 2020
bjope created this revision.
bjope added reviewers: lebedev.ri, materi.
Herald added a subscriber: hiraditya.
Herald added a project: LLVM.
bjope requested review of this revision.
The "takeName" logic at the end of ScalarizerVisitor::finish
could end up renaming global variables when having simplified
and extractelement instruction to simply pick a single vector
element. If the input vector to the extractelement instruction
held pointers to global variables we ended up renaming the global
variable.
The patch make sure we only take the name of the replaced Op when
we have added new instructions that might need a useful name.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D86472
Files:
llvm/lib/Transforms/Scalar/Scalarizer.cpp
llvm/test/Transforms/Scalarizer/basic.ll
llvm/test/Transforms/Scalarizer/global-bug.ll
Index: llvm/test/Transforms/Scalarizer/global-bug.ll
===================================================================
--- /dev/null
+++ llvm/test/Transforms/Scalarizer/global-bug.ll
@@ -0,0 +1,23 @@
+; RUN: opt < %s -scalarizer -S -o - | FileCheck %s
+; RUN: opt < %s -passes='function(scalarizer)' -S | FileCheck %s
+
+ at a = dso_local global i16 0, align 1
+ at b = dso_local local_unnamed_addr global i16 0, align 1
+
+; The scalarizer used to take the name of the extractelement instruction
+; ("extract") and put that on the extracted value, which in this test case is
+; the global variable @a. That was wrong, as we must not change the name of
+; the global variable. So make sure we find "@a" in the ptrtoint.
+define dso_local void @test1() local_unnamed_addr {
+; CHECK-LABEL: @test1(
+; CHECK-NEXT: entry:
+; CHECK-NEXT: [[T0:%.*]] = ptrtoint i16* @a to i16
+; CHECK-NEXT: store i16 [[T0]], i16* @b, align 1
+; CHECK-NEXT: ret void
+;
+entry:
+ %extract = extractelement <4 x i16*> <i16* @a, i16* @a, i16* @a, i16* @a>, i32 1
+ %t0 = ptrtoint i16* %extract to i16
+ store i16 %t0, i16* @b, align 1
+ ret void
+}
Index: llvm/test/Transforms/Scalarizer/basic.ll
===================================================================
--- llvm/test/Transforms/Scalarizer/basic.ll
+++ llvm/test/Transforms/Scalarizer/basic.ll
@@ -542,8 +542,8 @@
; See https://reviews.llvm.org/D83101#2133062
define <2 x i32> @f23_crash(<2 x i32> %srcvec, i32 %v1) {
; CHECK-LABEL: @f23_crash(
-; CHECK: %1 = extractelement <2 x i32> %srcvec, i32 0
-; CHECK: %t1.upto0 = insertelement <2 x i32> undef, i32 %1, i32 0
+; CHECK: %v0 = extractelement <2 x i32> %srcvec, i32 0
+; CHECK: %t1.upto0 = insertelement <2 x i32> undef, i32 %v0, i32 0
; CHECK: %t1 = insertelement <2 x i32> %t1.upto0, i32 %v1, i32 1
; CHECK: ret <2 x i32> %t1
%v0 = extractelement <2 x i32> %srcvec, i32 0
Index: llvm/lib/Transforms/Scalar/Scalarizer.cpp
===================================================================
--- llvm/lib/Transforms/Scalar/Scalarizer.cpp
+++ llvm/lib/Transforms/Scalar/Scalarizer.cpp
@@ -941,13 +941,13 @@
for (unsigned I = 0; I < Count; ++I)
Res = Builder.CreateInsertElement(Res, CV[I], Builder.getInt32(I),
Op->getName() + ".upto" + Twine(I));
+ Res->takeName(Op);
} else {
assert(CV.size() == 1 && Op->getType() == CV[0]->getType());
Res = CV[0];
if (Op == Res)
continue;
}
- Res->takeName(Op);
Op->replaceAllUsesWith(Res);
}
PotentiallyDeadInstrs.emplace_back(Op);
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D86472.287433.patch
Type: text/x-patch
Size: 2625 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200824/ce223104/attachment.bin>
More information about the llvm-commits
mailing list