[PATCH] D85794: [llvm][LV] Replace `unsigned VF` with `ElementCount VF` [NFCI]
Francesco Petrogalli via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Aug 19 13:52:04 PDT 2020
fpetrogalli added inline comments.
================
Comment at: llvm/lib/Transforms/Vectorize/LoopVectorize.cpp:6817
+ assert(!UserVF.Scalable && "scalable vectors not yet supported");
+ unsigned VF = UserVF.Min;
// Outer loop handling: They may require CFG and instruction level
----------------
rengolin wrote:
> Name overloading, but now with different types. this will cause confusion.
>
> Better to have `ElementCount VF = UserVF` and then use `VF.Min` locally.
Good point, done. This allowed some extra improvements like replacing `!UserVF.Min` with `UserVF.isZero()`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D85794/new/
https://reviews.llvm.org/D85794
More information about the llvm-commits
mailing list