[PATCH] D84242: [ValueTracking] Add UndefOrPoison/Poison-only version of relevant functions
Juneyoung Lee via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jul 28 11:10:53 PDT 2020
aqjune added inline comments.
================
Comment at: llvm/include/llvm/Analysis/ValueTracking.h:581
+ const Value *getGuaranteedNonUndefOrPoisonOp(const Instruction *I);
const Value *getGuaranteedNonPoisonOp(const Instruction *I);
----------------
aqjune wrote:
> nikic wrote:
> > As these functions are the same, I would just rename getGuaranteedNonPoisonOp to getGuaranteedNonUndefOrPoisonOp.
> I think splitting these two is good (even if their contents are actually the same) because users like PoisonChecking want to only consider poison values. What do you think?
Leave getGuaranteedNonPoisonOp only & left a comment at previous getGuaranteedNonUndefOrPoisonOp's uses saying that non-poison op and non-undef op are equivalent
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D84242/new/
https://reviews.llvm.org/D84242
More information about the llvm-commits
mailing list