[PATCH] D83252: [XCOFF] Enable symbol alias for AIX
Jason Liu via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jul 15 14:57:40 PDT 2020
jasonliu added inline comments.
================
Comment at: llvm/test/CodeGen/PowerPC/aix-alias.ll:18
+}
+
+ at bar_f = weak alias %FunTy, %FunTy* @foo_f
----------------
Xiangling_L wrote:
> I feel the naming convention here is kinda messy. It seems there are mainly two kind, one is aliasing to a variable `bar`, the other is aliasing to a function `foo_f`.
> I am suggesting to stick `bar` related alias, with `bar_xxx` and prabably use `foo_f_xxx` to refer to `foo_f` related alias.
> [eg.
> @foo_f_w = weak alias %FunTy, %FunTy* @foo_f
> ]
Agree. Renamed and reorganized the test.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D83252/new/
https://reviews.llvm.org/D83252
More information about the llvm-commits
mailing list