[PATCH] D83391: [NFC][Debugify] Rename OptCustomPassManager into DebugifyCustomPassManager

Vedant Kumar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jul 13 13:52:30 PDT 2020


vsk added inline comments.


================
Comment at: llvm/include/llvm/IR/LegacyPassManager.h:100
+/// needed.
+class DebugifyCustomPassManager : public legacy::PassManager {
+  DebugifyStatsMap DIStatsMap;
----------------
The layering for this seems a bit strange, as LegacyPassManager doesn't have much to do with 'debugify'. How does moving the class into Debugify.h, and the class implementation into Debugify.cpp sound? That way, the new-PM version of this can live in the same files.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D83391/new/

https://reviews.llvm.org/D83391





More information about the llvm-commits mailing list