[PATCH] D81256: Upgrade TypePromotionTransaction to be able to report changes in CodeGenPrepare
Jay Foad via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jul 6 12:53:39 PDT 2020
foad added inline comments.
================
Comment at: llvm/lib/CodeGen/CodeGenPrepare.cpp:2943
+bool TypePromotionTransaction::changed(
+ TypePromotionTransaction::ConstRestorationPt Point) {
----------------
Maybe `changedSince` would be a better name?
================
Comment at: llvm/lib/CodeGen/CodeGenPrepare.cpp:4955
}
- TPT.commit();
----------------
I still don't really understand whether this is an intentional change in behaviour, or just fixing the return value from optimizeMemoryInst.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D81256/new/
https://reviews.llvm.org/D81256
More information about the llvm-commits
mailing list