[PATCH] D82550: [SLPVectorizer] handle vectorized lib functions
Sanne Wouda via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jul 3 04:49:39 PDT 2020
sanwou01 marked 2 inline comments as done.
sanwou01 added inline comments.
================
Comment at: llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp:3042
}
- Function *Int = CI->getCalledFunction();
+ Function *F = CI->getCalledFunction();
unsigned NumArgs = CI->getNumArgOperands();
----------------
RKSimon wrote:
> NFC rename?
Sure, I can split that off
================
Comment at: llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp:4548
+ CF = Intrinsic::getDeclaration(M, ID, Tys);
}
----------------
RKSimon wrote:
> This looks like a separate NFC?
Not sure if I'd call this NFC. It fixes a crash when !UseIntrinsic and there is no intrinsic, only a LibFunc, for the call. This patch makes that condition possible here.
Could do as a separate patch though, if that makes sense.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D82550/new/
https://reviews.llvm.org/D82550
More information about the llvm-commits
mailing list