[PATCH] D82820: [InstCombine] Fix mismatched attribute lists for combined calls

Vitaly Buka via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jun 29 18:34:40 PDT 2020


vitalybuka added inline comments.


================
Comment at: llvm/include/llvm/IR/Attributes.h:691
+  }
+
   //===--------------------------------------------------------------------===//
----------------
Is this
```
AttributeList LdexpAttrs = Attrs.shuffle<-1, 0, 1, 1>(B.getContext());
```

about the same as

```
   AttributeList LdexpAttrs;
   LdexpAttrs.addAttributes(Ctx, -1, Attrs.getAttributes(-1))
   LdexpAttrs.addAttributes(Ctx, 0, Attrs.getAttributes(0))
   LdexpAttrs.addAttributes(Ctx, 1, Attrs.getAttributes(1))
   LdexpAttrs.addAttributes(Ctx, 2, Attrs.getAttributes(1))

```

I think later is easier to read than format.
maybe as a for loop


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D82820/new/

https://reviews.llvm.org/D82820





More information about the llvm-commits mailing list