[PATCH] D82363: [DebugInfo] Add new instruction and expression operator for variadic debug values

Adrian Prantl via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 26 10:55:45 PDT 2020


aprantl added a comment.

> Is there an overlap of the DW_OP_LLVM_arg with the D70642 <https://reviews.llvm.org/D70642>?

I think the preferred way of resolving this would be to post to llvm-dev and make sure the authors of D70642 <https://reviews.llvm.org/D70642> are CC'ed. As far as I can see D70642 <https://reviews.llvm.org/D70642> is less space-efficient, but allows for referring to the same argument multiple times. Given the DW_OP_dup/over operators, I'm not sure if that is necessary.

Other than that, (apologies for the bike-sheddingI find the name confusing, because in the context of debug info, I'd associate "var" with "variable" and not with "variadic". `DBG_VALUES`, `DBG_VALUE_MULTI`? Or we could rename `DBG_VALUE` to `DBG_VALUE_LEGACY` and use `DBG_VALUE` for the new format, if we plan for it to completely replace it.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D82363/new/

https://reviews.llvm.org/D82363





More information about the llvm-commits mailing list