[PATCH] D82459: [AMDGPU] Make sure to fix implicit operands on insertBranch

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jun 24 09:09:32 PDT 2020


arsenm added inline comments.


================
Comment at: llvm/lib/Target/AMDGPU/SIInstrInfo.cpp:2274
     preserveCondRegFlags(CondBr->getOperand(1), Cond[1]);
+    fixImplicitOperands(*CondBr);
 
----------------
Preexisting complaint, but this function name is bad (and we should really be defining separate wave32 instructions anyway)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D82459/new/

https://reviews.llvm.org/D82459





More information about the llvm-commits mailing list