[PATCH] D82363: [DebugInfo] Add new instruction and expression operator for variadic debug values
Djordje Todorovic via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jun 23 05:49:30 PDT 2020
djtodoro added a comment.
@StephenTozer Thanks for this!
Is there an overlap of the `DW_OP_LLVM_arg` with the D70642 <https://reviews.llvm.org/D70642>?
`DBG_VAL_VAR` stands for //variadic//, any alternative for the name? //VAR// may indicate to '//variable//' I think...
Another question/concern (may be too early): the Salvage Debug Info feature when supporting multiple SSA values may produce an exploded/very huge number of //dbg_values// I think, so we may want to introduce a magic value to cut off the input if it is too big. Have you encountered such situation?
================
Comment at: llvm/test/CodeGen/MIR/Generic/dbg-value-var-spill.mir:55
+ ; Function Attrs: nounwind
+ declare void @llvm.stackprotector(i8*, i8**)
+
----------------
unused
================
Comment at: llvm/test/CodeGen/MIR/Generic/dbg-value-var.mir:23
+ ; Function Attrs: nounwind
+ declare void @llvm.stackprotector(i8*, i8**)
+
----------------
unused
================
Comment at: llvm/test/CodeGen/MIR/Generic/dbg-value-var.mir:53
+exposesReturnsTwice: false
+legalized: false
+regBankSelected: false
----------------
Most of these MF attributes are unused, so we can get rid of them.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D82363/new/
https://reviews.llvm.org/D82363
More information about the llvm-commits
mailing list