[PATCH] D81236: Improve LegacyPassManager API to correctly report modified status
serge via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Jun 21 03:41:39 PDT 2020
serge-sans-paille marked 2 inline comments as done.
serge-sans-paille added inline comments.
================
Comment at: llvm/include/llvm/IR/LegacyPassManagers.h:333
- virtual Pass *getOnTheFlyPass(Pass *P, AnalysisID PI, Function &F);
+ virtual std::tuple<Pass *, bool> getOnTheFlyPass(Pass *P, AnalysisID PI,
+ Function &F);
----------------
nikic wrote:
> Just wondering, why std::tuple rather than std::pair?
Because I find `std::get<bool>(PassStatus)` easier to read than `std::get<1>(PassStatus)` or `PassStatus.second`. No strong opinion here though :-)
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D81236/new/
https://reviews.llvm.org/D81236
More information about the llvm-commits
mailing list