[PATCH] D78896: [Support] Add file lock/unlock functions

Serge Pavlov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 19 00:29:47 PDT 2020


sepavloff updated this revision to Diff 271931.
sepavloff added a comment.

Updated patch

Changed name of the function `tryLockFileWithTimeout` to `tryLockFile`. This
name is shorter thus more readable. Expression like `tryLockFile(SomeFile)`
looks natural, `tryLockFile(SomeFile, 2500ms)` also is understandable without
documentation. Setting default timeout value to zero is natural, as a single
attempt to lock, which is associted with `try*` functions, can be considered
as a particular case of very short timeout.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D78896/new/

https://reviews.llvm.org/D78896

Files:
  llvm/include/llvm/Support/FileSystem.h
  llvm/lib/Support/Unix/Path.inc
  llvm/lib/Support/Windows/Path.inc
  llvm/unittests/Support/ProgramTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D78896.271931.patch
Type: text/x-patch
Size: 7922 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200619/295db7d6/attachment.bin>


More information about the llvm-commits mailing list