[PATCH] D81826: [DWARFYAML][debug_abbrev] Make the abbreviation code optional.

George Rimar via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jun 17 02:40:10 PDT 2020


grimar added inline comments.


================
Comment at: llvm/include/llvm/ObjectYAML/DWARFYAML.h:55
 struct Abbrev {
-  llvm::yaml::Hex32 Code;
+  Optional<uint64_t> Code;
   llvm::dwarf::Tag Tag;
----------------
Higuoxing wrote:
> jhenderson wrote:
> > I would suggest you keep this as a `Hex64` in this patch, and change it to a `uint64_t` in a separate patch, although I'm not entirely convinced either way whether it should be done at all. Perhaps @grimar has some thoughts?
> Sure, I will leave it as `yaml::Hex64` in this patch. I think dumping abbreviation codes in a decimal format has better readability than dumping it in a hexadecimal format. But I'm convincible here :)
I'd change to `uint64_t`, but separatelly. I think that abbreviation codes in a decimal format would probably look better, because it is just an index? 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D81826/new/

https://reviews.llvm.org/D81826





More information about the llvm-commits mailing list