[PATCH] D72425: [OptRemark] RFC: Introduce a message table for OptRemarks

Francis Visoiu Mistrih via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 16 18:38:23 PDT 2020


thegameg added inline comments.


================
Comment at: llvm/include/llvm/Remarks/OptRemarkDiagBase.td:23
+
+def Kind_General : OptRemarkKind<"General">;
+def Kind_Missed : OptRemarkKind<"Missed">;
----------------
andrew.w.kaylor wrote:
> thegameg wrote:
> > I think a few places call this "Passed". Would that be better than "General"?
> I don't like "Passed" but "General" isn't very helpful either. I think this will apply to "optimizations that were performed" as opposed to missed opportunities and "analysis" (which seems to mean "information"), but I'm not sure there are no cases where the base OptimizationRemark class is used to mean something else.
> 
> The clang documentation describes the groups this way:
> 
>   # When the pass makes a transformation (-Rpass).
>   # When the pass fails to make a transformation (-Rpass-missed).
>   # When the pass determines whether or not to make a transformation (-Rpass-analysis).
> 
> That last description seems bad.
> 
> I don't really have strong feelings about what we call it. I guess what's important is to give it a good enough name that someone won't accidentally use if for a remark that doesn't align with the intended use. "General" doesn't do that. I guess "Passed" does.
No strong feelings either, I agree with everything you said.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72425/new/

https://reviews.llvm.org/D72425





More information about the llvm-commits mailing list