[PATCH] D59553: [WIP][LLD][ELF][DebugInfo] Use predefined value to mark debug address ranges pointing to deleted code.
Fangrui Song via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Jun 13 01:02:27 PDT 2020
MaskRay added a comment.
I know that you have posted the patch for one year and spent much time on it. It would seem that I deprived the patch if I created a new one. Apologies that I just created D81784 <https://reviews.llvm.org/D81784> to hopefully capture all the previous discussions. A bit more items why I started a new one:
- We don't need to special case `.zdebug_*` => actually we are thinking of dropping input `.zdebug_*` support (I am sorry that our internal toolchain still depends on it, so I can't remove it even if the community feels that dropping it is ok).
- R_X86_64_32 should not be checked. We should use `target->symbolicRel`
- We don't need `*-gc-sections-debug-data-64.s` for every target. The feature is sufficiently generic - x86_64 + x86 covers most cases. `symbolRel` logic has separately be checked in many tests.
- `gc-sections` is not a generic name. /DISCARD/, non-prevailing section group, ICF can create similar scenarios. We should use a generic test case.
- I want to explicitly check that addend is ignored.
- I want to a more comprehensive summary and call out to what is fixed and what isn't (non-prevailing section group).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D59553/new/
https://reviews.llvm.org/D59553
More information about the llvm-commits
mailing list