[PATCH] D81495: [SVE] Remove invalid calls to VectorType::getNumElements from BasicTTIImpl

Christopher Tetreault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 9 17:09:38 PDT 2020


ctetreau marked an inline comment as done.
ctetreau added inline comments.


================
Comment at: llvm/include/llvm/CodeGen/BasicTTIImpl.h:90
+  /// to be able to call getNumElements().
+  FixedVectorType *FIXME_ScalableVectorNotSupported(VectorType *VTy) {
+    assert(isa<FixedVectorType>(VTy) &&
----------------
ctetreau wrote:
> I think it's reasonable to bikeshed this name. I picked `FIXME_ScalableVectorNotSupported` because I wanted a name that is very aggressive in expressing that it's a fixme conversion. However, I recognize that it doesn't strictly conform to our documented coding style.
I went ahead and removed the helper.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D81495/new/

https://reviews.llvm.org/D81495





More information about the llvm-commits mailing list