[PATCH] D81448: [CostModel] Unify Shuffle and InsertElement Costs

Sam Parker via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 9 01:36:37 PDT 2020


samparker created this revision.
samparker added reviewers: dfukalov, arsenm, uweigand, RKSimon, spatel.
Herald added subscribers: kerbowa, dmgreen, hiraditya, tpr, nhaehnle, wdng, jvesely.
Herald added a project: LLVM.

Extract the existing code from getInstructionThroughput into TTImpl::getUserCost. The duplicated code in the AMDGPU backend has also been removed.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D81448

Files:
  llvm/include/llvm/Analysis/TargetTransformInfoImpl.h
  llvm/lib/Analysis/TargetTransformInfo.cpp
  llvm/lib/Target/AMDGPU/AMDGPUTargetTransformInfo.cpp
  llvm/test/CodeGen/SystemZ/splitMove_undefReg_mverifier.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D81448.269434.patch
Type: text/x-patch
Size: 6915 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200609/cdd77d35/attachment-0001.bin>


More information about the llvm-commits mailing list