[PATCH] D81230: Correctly report modified status for LoopIdiomRecognize

Alina Sbirlea via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 5 13:33:00 PDT 2020


asbirlea added a comment.

Any chance of adding a test for this?



================
Comment at: llvm/lib/Transforms/Scalar/LoopIdiomRecognize.cpp:1091
 
-  if (avoidLIRForMultiBlockLoop())
+  if (avoidLIRForMultiBlockLoop()) {
+    Expander.clear();
----------------
Merge conditions to avoid the code duplication?
```
if (mayLoopAccessLocation(...) || 
    avoidLIRForMultiBlockLoop) { 
```


================
Comment at: llvm/lib/Transforms/Scalar/LoopIdiomRecognize.cpp:1118
     const MaybeAlign LoadAlign = LI->getAlign();
-    if (StoreAlign == None || LoadAlign == None)
+    if (StoreAlign == None || LoadAlign == None) {
+      Expander.clear();
----------------
Similarly, merge conditions and comment appropriately.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D81230/new/

https://reviews.llvm.org/D81230





More information about the llvm-commits mailing list