[PATCH] D81144: [MC] Generate .debug_line in the 64-bit DWARF format [2/7]
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jun 4 05:57:22 PDT 2020
jhenderson added inline comments.
================
Comment at: llvm/lib/MC/MCDwarf.cpp:487
+ emitAbsValue(*MCOS,
+ MakeStartMinusEndExpr(context, *LineStartSym, *LineEndSym,
+ UnitLengthBytes),
----------------
Aside: I think this function may be misnamed - shouldn't it be `MakeEndMinusStartExpr`?
================
Comment at: llvm/test/MC/ELF/gen-dwarf64.s:20
+# DUMP5-NEXT: file_names[ 0]:
+# DUMP5-NEXT: name: .debug_line_str[0x00000000[[FILEOFF:[[:xdigit:]]{8}]]] = "[[FILE:.+]]"
+# DUMP5-NEXT: dir_index: 0
----------------
FileCheck has relatively recently been extended to improve numeric variable capturing. You can change this line to something like:
`name: .debug_line_str[0x00000000[[#FILEOFF:]]] = "[[FILE:.+]]"`
and the usage to: `0x[[#FILEOFF]]`.
Beware that there are some issues relating to leading zeros that I can't quite remember the details of.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D81144/new/
https://reviews.llvm.org/D81144
More information about the llvm-commits
mailing list