[PATCH] D80684: [LiveDebugValues] Speed up removeEntryValue, NFC

Adrian Prantl via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 29 14:46:52 PDT 2020


aprantl added inline comments.


================
Comment at: llvm/lib/CodeGen/LiveDebugValues.cpp:477
     /// within Loc2Vars.
     std::map<VarLoc, uint32_t> Var2Index;
 
----------------
vsk wrote:
> aprantl wrote:
> > Side-note: does this get more readable if we introduce a typedef for uint32_t here, such a `VarLocIndex`?
> That may look a little too similar to "LocIndex". Wdyt of `LocIndex::uint32_location_t` and `LocIndex::uint32_index_t`?
sure!


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80684/new/

https://reviews.llvm.org/D80684





More information about the llvm-commits mailing list