[PATCH] D80530: [AMDGPU][MC][GFX908] Corrected src0 of v_accvgpr_write to accept only VGPRs and inline constants.

Stanislav Mekhanoshin via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 26 10:17:18 PDT 2020


rampitec added inline comments.


================
Comment at: llvm/lib/Target/AMDGPU/AsmParser/AMDGPUAsmParser.cpp:1349
   bool validateVOP3Literal(const MCInst &Inst) const;
+  bool validateMAIAccLoad(const MCInst &Inst);
   unsigned getConstantBusLimit(unsigned Opcode) const;
----------------
Can you rename it to validateMAIAccWrite? This is not a load.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80530/new/

https://reviews.llvm.org/D80530





More information about the llvm-commits mailing list