[PATCH] D80341: [SVE] Eliminate calls to default-false VectorType::get() from polly

Francesco Petrogalli via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 21 09:41:52 PDT 2020


fpetrogalli accepted this revision.
fpetrogalli added a comment.
This revision is now accepted and ready to land.

LGTM, with one nit that I think it is worth addressing before submitting.

Thank you



================
Comment at: polly/lib/CodeGen/BlockGenerators.cpp:1108
   auto *Pointer = Load->getPointerOperand();
-  VectorType *VectorType = VectorType::get(
+  auto *VectorType = FixedVectorType::get(
       dyn_cast<PointerType>(Pointer->getType())->getElementType(), VectorWidth);
----------------
While on this, maybe rename the variable `VectorType` to something that doesn't confuse the types? `VecTy`?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80341/new/

https://reviews.llvm.org/D80341





More information about the llvm-commits mailing list